giúp em fix lỗi biên dịch file apk với các pro ơi

Thảo luận trong 'Thủ thuật - Sử dụng Android' bắt đầu bởi huynhngoclinh000, 6 Tháng hai 2015.

  1. huynhngoclinh000

    huynhngoclinh000 New Member

    Tham gia ngày:
    5 Tháng hai 2015
    Bài viết:
    22
    Đã được thích:
    0
    khi đầu bị lỗi này
    W: Could not find sources
    aapt: warning: string 'data_connection_datach_timeout_error_msg' has no default translation in /sdcard/apktool/SystemUI_src/res; found: de es fr in it ms pt tr vi
    I: Using Apktool 2.0.0-Beta7 on SystemUI_src
    I: Building resources...
    I: Building apk file...

    sau khi em sửa lỗi trên bằng cách xoá các dòng string 'data_connection_datach_timeout_error_msg' bên file vaubli.es de in it vi đại loại là các dòng string 'data_connection_datach_timeout_error_msg' trong file vaubli.de es fr in it ms pt tr vi

    sau khi sửa xong thì nó bị lỗi này
    W: Could not find sources
    /sdcard/apktool/SystemUI_src/res/values/public.xml:621: error: Public symbol string/data_connection_datach_timeout_error_msg declared here is not defined.
    /sdcard/apktool/SystemUI_src/res/values/public.xml:620: error: Public entry identifier 0x7f0900a4 entry index is larger than available symbols (index 164, total symbols 164).
    /sdcard/apktool/SystemUI_src/res/values/public.xml:620: error: Public symbol string/toast_rotation_locked declared here is not defined.
    Exception in thread "main" brut.androlib.AndrolibException: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 16, --target-sdk-version, 16, --version-code, 16, --version-name, 4.1.2, -F, /data/data/per.pqy.apktool/APKTOOL7234306605653331426.tmp, -0, arsc, -I, ?/apktool/framework/1.apk, -S, /sdcard/apktool/SystemUI_src/res, -M, /sdcard/apktool/SystemUI_src/AndroidManifest.xml]
    at brut.androlib.Androlib.buildResourcesFull(Androlib.java:434)
    at brut.androlib.Androlib.buildResources(Androlib.java:362)
    at brut.androlib.Androlib.build(Androlib.java:285)
    at brut.androlib.Androlib.build(Androlib.java:258)
    at brut.apktool.Main.cmdBuild(Main.java:233)
    at brut.apktool.Main.main(Main.java:88)
    Caused by: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 16, --target-sdk-version, 16, --version-code, 16, --version-name, 4.1.2, -F, /data/data/per.pqy.apktool/APKTOOL7234306605653331426.tmp, -0, arsc, -I, ?/apktool/framework/1.apk, -S, /sdcard/apktool/SystemUI_src/res, -M, /sdcard/apktool/SystemUI_src/AndroidManifest.xml]
    at brut.androlib.res.AndrolibResources.aaptPackage(AndrolibResources.java:481)
    at brut.androlib.Androlib.buildResourcesFull(Androlib.java:415)
    ... 5 more
    Caused by: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 16, -


    nhưng lỗi này là lỗi gì em ko biết .. anh giúp em với
    hay e gửi file system.apk a fix lỗi giúp em thì tốt
     

Chia sẻ trang này